Crush on Radeon 6550M

Home Forums Support Crush on Radeon 6550M

Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6460
    Shukfir
    Participant

    A problem. If starting a new game with high graphic settings, the game just crushes.

    If starting with low graphic settings, it starts, but crushes when I scroll my mousewheel to look closer at vehicle or city buildings.

    I’ve checked Device Manager – it shows, that I have only 1 display adapter – AMD Radeon HD 6550M (Windows 7 64-bit).

    I’ve installed the latest drivers and reboot the system – the problem still remain.

    • This topic was modified 6 years, 4 months ago by Shukfir.
    #6735
    fredbertelmann
    Participant

    Hello, i have exactly the same problem. my laptop works with Intel core i5 M480 2.67GHz and AMD Radeon HD 6530M.

    I have to set on low geometry, rest can be high, to start a map. with middle and high geometry it doesnt even start and crash immidiatly.

    when everything is low, i can scroll into the map and it looks fine but then changing the view at some houses of a town let it crash again. at a wider look i can scroll over towns. but scrolling into them fails.

    one more problem: at low resolution my window for my resolution options disappears, so that i cant change it again to higher / other ones.

    Perhaps you can help us with this, thx!

    #7082
    Shukfir
    Participant

    My problem is solved. Thanks everyone for help.

    fredbertelmann, try to Automatically Detect and Install the latest driver from official AMD site:

    http://support.amd.com/en-us/download

    Previously I installed driver from non-official site, and, as I’ve understood for now, it wasn’t the latest.

    • This reply was modified 6 years, 4 months ago by Shukfir.
    • This reply was modified 6 years, 4 months ago by Shukfir.
    • This reply was modified 6 years, 4 months ago by Shukfir.
    #7098
    Nique
    Participant

    Never seen someone having a crush on a videocard. totally new to me 😛

    #7101
    fredbertelmann
    Participant

    damn nice, Shukfir thx for this hint!!!

    it works super!!

    #7268
    Shukfir
    Participant

    Nique, sorry, but I don’t speak English. My native language is Englesh. 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Support’ is closed to new topics and replies.