Graphics-Bug: Trees in the Skies!

Home Forums Support Graphics-Bug: Trees in the Skies!

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #20951

    First I want to thank the developers for this great game I just discovered these winter holidays!!! (I’m a big fan of TTD/OTTD and now finally I found a worthy successor only now, in Train Fever)

    The game works perfectly on my main computer, with an Nvidia 250 GTS, Linux.

    I was surprised, that TF also works relatively smooth on my laptop a Lenovo T420 (also running Linux, Ubuntu 15.10), i5 3,2GHz, 16GB RAM, Intel HD3000 (I thought these cards were not supported, however, the game works surprisingly fast and I can also load “big” save-games from my other computer without trouble!)

    The only Problem:

    All trees in the game seem to be rendered on a separate layer which “flows” in the air, when viewed from far away. When I zoom in, the trees appear normally. This phenomenon is independent from the geometric detail setting (low/medium/high).

    See screenshots:
    Far away


    The trees appear only when you move very near:

    My guess is that TF uses different layers for rendering near or far away objects for performance reasons. However, the layer for the far away trees (and only the trees!) seems to cause problems (probably OpenGL-related?). As the rest of the game works without problems, I would also be satisfied if there was a (hidden) option in a config-file to disable the “far-away” rendering for trees, as a workaround.

    The rest of the game works fine, even with reflections enabled and complex tracks (Ok, without AA):

    I really would like to be able to play the game also on my laptop, and because its such a great game I would also buy a second copy to be independent from the steam-account and to support the developers, if they could fix this problem.

    The problem was observed with:

    TF Build 6219 Linux 64-Bit

    Another guess what could be the problem:

    I heard from someone that the Linux-driver for the Intel integrated graphics cards “emulates” features which are not implemented in the hardware by software-rendering (don’t know if that’s true). Therefore it could be that the hardware does not meet exactly the OpenGL requirements, but the driver gets it to work anyway.

    The toool glxinfo says (among others):
    OpenGL version string: 3.0 Mesa 11.0.2
    OpenGL shading language version string: 1.30

    So it’s true that the OpenGL-Version mentioned here is < 3.2, however as I just said the rest of the game works fine. I would appreciate it very much if there could be some kind of fix/workaround (even to disable trees). Maybe the game could reach even more users, if there are only such small issues on Intel-graphics-cards…

    For responses, I also speak German 🙂




    This is a very rare problem which only seems to show up when an Intel HD3000 on a Linux system is used. Unfortunately there is no fix yet to solve it.

    But if it would be enough for you to remove / hide the trees, I will be happy to provide you with a simple mod that prevents the engine from rendering the trees at a certain camera distance.

    Just write me a short email to info (at) and I can send it to you.

    Best Regards,

    PS: If you write the mail, German is fine for me too 😉

    • This reply was modified 8 years, 3 months ago by admin.
Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘Support’ is closed to new topics and replies.