Help the USA DlC Does not work

Home Forums General Discussion Help the USA DlC Does not work

Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #17199
    ratje48
    Participant

    Hi,

    I just downloaded the usa dlc, but it does not seem to work. When I start a new game and try to select the USA game mode nothing happens, I can’t press that button. I reinstalled the game, still doesn’t work. Can somebody help me please?

    #17201
    pdguru
    Participant

    Download the DLC from Steam page for Train Fever.  But be warned – old save games with mods will not work.  And the buildings don’t seem to be working in the DLC anyhow.

    #17207
    kimmaz
    Participant

    Yea, I downloaded a 40mb patch and got a new main menu. But i figured out that i had to go to the store and buy the free dlc and then download it as well. this time it is 550mb. Nice to see some size on it! Its almost done.

    #17209
    pdguru
    Participant

    I repeat – be warned – old save games with mods will not work.  And the buildings don’t seem to be working in the DLC anyhow.  Bavarian chalets in the desert.  Kinda cute.

    #17210
    simonmd
    Participant

    Just to make it clear, the Auto update is NOT the USA DLC. It is ONLY a patch that updates the game and adds the framework that this and no doubt, future DLC packs can use. The actual USA DLC is over 500mb.

    To download the actual USA content, you need to open your steam page, select ‘Train Fever’ and then click on the ‘DLC’ option on the menu on the right hand side, near the top of the screen. You can then download and install it just as you would any other addon, the only difference being there is no checkout as it’s free.

    #17212
    kimmaz
    Participant

    Well I just started the game and LOADED a previus game i played on last night. It works for me! Didnt even delete/verfity anything.

    But forget that, ill start some new game with freekin dezzerts _:D

    #17213
    simonmd
    Participant

    +1 for me, don’t panic people with mods. Admittedly, I have just had a reinstall due to a new PC build but the mods I did have, namely ‘depot pack, signals pack and fake trains’ seem to be working fine. A relief as I had built a very nice junction with 5 platforms and a goods station!

    Right, I’m off to the wild west…….

    #17220
    pdguru
    Participant

    Won’t load save game with modded engines (for me at least).  Crashes at game load.

    #17227
    pdguru
    Participant

     

    UPDATE:  Works for old game saves with mods now.  Removed tfmm file and loaded just the mod res folders into the newly uploaded res folder.  Also continues to work with Reshade (pics above)

     

    • This reply was modified 5 years, 10 months ago by pdguru.
    • This reply was modified 5 years, 10 months ago by pdguru.
Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.