Mac LUA error crash

Home Forums Support Mac LUA error crash

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8391
    captainpezzles
    Participant

    Hey all,

    Having a bit of a problem here. I get as far as choosing game world settings and try to launch a new game and I get stuck on a black screen. No loading screen pops up before the game will simply exit back to steam after a few minutes. I set graphics to lowest and adjusted resolution, however when I tried launching a new game while in windowed mode and as soon as I click start the following LUA error message pops up:
    File: res/models/model/.DS_Store

     
    res/models/model/.DS_Store:1: unexpected symbol

    After clicking ok the game exits back to steam before getting a “Train Fever quit unexpectedly” message pop up.

    Has anyone encountered this before and if so, have you been able to fix this? Right now game is totally unplayable.

    System specs:

    Macbook pro 15inch 2012

    OS X 10.9.4,  4GB Ram, Graphics – AMD Radeon HD 6750M 512 MB

    Thanks.

    #8394
    ma2412
    Participant

    Mods on OSX mostly do not work, you have to reinstall the game in most cases.

    Macs do not merge folders, so try to copy every files by stepping through each folder.

     

    @devs: will there be a mod manager within the game in the future?

    if not, anyone with Java knowledge can make a simple MOD manager for all platforms?

    #8396
    captainpezzles
    Participant

    Hey there.

    I’m not using mods for this. This is trying to run the game in ‘factory’ state. I have also tried doing a fresh install but no luck.

    #8398
    olahaldor
    Participant

    I’ve experienced the same thing. I think it happens because of new files in the folders, Mac OS will try to generate thumbnails and other metadata for the files.

     

    You can remove all .ds_store files on the entire system by doing this:

    1. Open a Terminal window.
    1. Enter the following UNIX command: (i recommend you COPY/PASTE this)

      sudo find / -name “.DS_Store” -depth -exec rm {} \;

    2. When prompted for a password enter your Mac OS X Administrator password.

    That’s what I found after some googling. I’m not sure how I can make it delete .ds_store files for the Train Fever res folders only though.

    Let it work its magic for a minute, and start the game.

    #8399
    olahaldor
    Participant

    double post. Delete this post.

    • This reply was modified 6 years, 4 months ago by olahaldor.
    #8433
    captainpezzles
    Participant

    Thanks olahaldor!

    While that didn’t resolve the problem it put me in the right direction. For some reason using terminal wasn’t deleting the .DS_store file in the train fever directory. However, I did uninstall TF via steam using the “delete local content” button. However, as I suspected, this deleted all the contents of the resources/models/model directory but not the actual folders themselves so the .DS_store file was still there. I deleted all the remaining TF files and folders from the Steam directory and did a fresh install which has fixed the problem. Hopefully doing things this way will solve the issue for anyone else that encounters the same problem.

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Support’ is closed to new topics and replies.