openGL context creation failed (game does not start)

Home Forums Support openGL context creation failed (game does not start)

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #7449

    This is what it says : [Please try installing the latest drivers for your graphics card] (ARB_timer_query not available).  I use Ubuntu 14.04 64 bit and Radeon HD 4670, and I can’t update drivers because AMD stopped supporting my gfx card. All other games work flawless on default opensource drivers.


    i was wondering there is meant to be a settings file to change graphics settings manually.

    this i obviously not on mine as never ran for a first time. maybe getting that file and manually setting might provide a work around??


    anyone willing to send me there setting file?



    Thank you for reporting this. We’re going to remove the ARP_timer_query and use a different solution. Stay tuned for the next update.


    The settings file on linux can be found here:



    Thank you very much for the reply. Looking forward to play TF.
    Here are some spec of my computer, maybe this will help.

    Some glxinfo:
    OpenGL version string: 3.0 Mesa 10.1.3
    server glx vendor string: SGI
    client glx vendor string: Mesa Project and SGI
    OpenGL vendor string: X.Org
    direct rendering: Yes
    and other info
    Processor : 4x AMD Athlon(tm) II X4 620 Processor
    Memory : 4047MB (903MB used)
    Operating System : Ubuntu 14.04.1 LTS
    Date/Time : pią, 12 wrz 2014, 10:47:37
    Resolution : 1680×1050 pixels
    OpenGL Renderer : Gallium 0.4 on AMD RV730
    X11 Vendor : The X.Org Foundation
    Audio Adapter : HDA-Intel – HDA ATI SB
    Audio Adapter : HDA-Intel – HDA ATI HDMI


    i can`t find that is there a filename i can search via



    i only have

    crash dump and save folders in them nothing at all.





    I can give you the content of the settings.lua file which should be placed in the /local/ folder. I dont think this will change anything. What is your error ? What system do you have?


    settings.lua file:

    function data()

    return {

    fullScreen = true,

    geometryQuality = 2,

    invertPan = false,

    invertRotate = false,

    invertRotateKeys = false,

    invertTilt = false,

    invertZoom = false,

    masterVolume = 0.30000001192093,

    maxDegreeOfAnisotropy = 4,

    menuMusicEnabled = true,

    moneyMode = “KMB”,

    moneyPrefix = “$”,

    moneySuffix = “”,

    musicEnabled = true,

    musicVolume = 0,

    numSamples = 2,

    scrollAtBorder = true,

    shadowQuality = 0,

    soundVolume = 0.60000002384186,

    speedUnit = “KMH”,

    uploadCrashDumps = true,

    use16bitTextures = true,

    useHdr = false,

    useReflection = false,

    useSsao = false,

    useTextureCompression = false,

    vsync = true,

    windowPos = {

    1920, 0,


    windowSize = {

    1920, 1200,






    I’have tried to upgrade my OpenGL version:

    server glx version string: 1.4
    client glx version string: 1.4
    GLX version: 1.4
    OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.4.0-devel (git-2828680 2014-09-12 trusty-oibaf-ppa)
    OpenGL core profile shading language version string: 1.40
    OpenGL version string: 3.0 Mesa 10.4.0-devel (git-2828680 2014-09-12 trusty-oibaf-ppa)
    OpenGL shading language version string: 1.30
    OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.4.0-devel (git-2828680 2014-09-12 trusty-oibaf-ppa)
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0

    It is still not the latest. I’m fighting my system to get OpenGL 3.3 through but currently it dosent get me 3.3. Still fighting.


    Hi, I have a problem with open Gl, game not start. I have nvidia geforce GT555M.  Can you help me please.


    Still waiting for ARB_timer_query patch.


    same here i realy want to play this game and especially cause american pack is commming out. i have Mobile Intel(R) 4 Series Express Chipset Family is thier anyway that u guys can lower the graphics level insted of me buying another PC


Viewing 11 posts - 1 through 11 (of 11 total)
  • The forum ‘Support’ is closed to new topics and replies.