[Optimization] Huge pauses/lag in game

Home Forums Support [Optimization] Huge pauses/lag in game

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #16087
    HPoltergeist
    Participant

    Hi Guys!

     

    First of all, you’ve made a fine and detailed game! Good job!

    But:

    I have a serious problem. After a couple of hours played the game starts to have pauses terribly. For example for every 5 sec of playtime there is a 10 sec pause/lag in the game.

    It makes the game almost unplayable, that’s why I’ve stopped playing it.

    As I saw the game makes saves of the size of 0,5 GB or so. That’s quite huge, also to handle these, can cause the mentioned pauses in game on autosaves and on other calculations.

    Maybe there is something that needs to be optimized badly.

    My PC:

    AMD FX 8120

    ASUS M5A99X EVO

    8GB DDR3 1666MHz

    ASUS Radeon R9 270X TOP 2GB

    OCZ Vertex 3 SSD

    Please do something about it, I don’t think my PC is the problem. =)

    Thank you very much for your efforts and the good game,

    HP

    #16090
    simonmd
    Participant

    If you read this forum more, you’ll find that performance is the BIG NUMBER ONE in the looooonnnnggg list of complaints. I’m afraid you’re correct, it’s not your system, it’s the game’s core not being optimised to use hyperthreading properly, ie, it doesn’t make proper use of multicore CPUs , only using one or two of the cores at most which after a couple of hours of play, grinds the game to a halt.

    I personally LOVE this game but have given up trying to play it as when I just start to make real progress, I get the same problem which makes it totally unplayable. I only keep popping in here to look for news of a potential fix but so far, all we’ve really got are silly little patches that don’t address the main problems. Simple fact is, we’ve all paid for a game that is no more than than an Alpha or Beta version at best and now we have done so, all we can do is hope the devs can eventually fix it.

    • This reply was modified 6 years ago by simonmd.
    • This reply was modified 6 years ago by simonmd.
    #16094
    Blokker_1999
    Participant

    If you read trough http://www.train-fever.com/forums/topic/req-multithreading-performance-issu-large-map/ you will find a detailed analysis of the problem.

    #16105
    Varana
    Participant

    There’s also some kind of performance loss with playing time. If the game runs uninterrupted for a long time, performance suffers. I’ve resorted to quitting and restarting the game about every two hours, which alleviates the issue somewhat.

    #16110
    HPoltergeist
    Participant

    Thank you guys very much for your answers. That’s true, not much I’ve looked into the previous topics, I’m sorry for that.

    But, I’ve also haven’t found any connecting topics and I won’t read through all of the 40 or so “one or two word title” topics sometimes in foreign language. If this is really that huge and prioritized issue, it should be a fixed topic amongst the first few ones or at least in the most common issues section.

    So I join the club, waiting for the fix for this. Then I’ll continue playing. =)

    Thank you,

    HP

    #16514
    HPoltergeist
    Participant

    Is there already a solution for this problem?

    HP

    #16517
    HPoltergeist
    Participant

    Ohh I see the updates! I’ll test it soon.

    Thanks,

    HP

    #16557
    Blokker_1999
    Participant

    Unfortunatly, the update did not solve this issue for me.

    #16561
    HPoltergeist
    Participant

    I can tell almost the same.

    There are still many huge pauses in game (independently of autosaves) after placing, converting a route segment, or just randomly.

    This game still needs huge optimizations. But, at least more or less it’s playable now.

    Also I have some other problems with the game what I’ll detail later in an other thread.

    HP

    #16747
    HPoltergeist
    Participant

    Up.

    HP

    #16895
    HPoltergeist
    Participant

    Up2.

    HP

    #16947
    tomtom
    Participant

    On the latest build I am still getting the end of month lag.

    i5 4690K @ 4.4GHz, 8GB Ram, game stored on an SSD.

    Everything was going well until the 1920’s when I added several cities to my network. I intentionally have not created any super cities quickly (largest is only 628 citizens on a large map).

    I don’t understand why the game has to calculate so much at the end of the month, still on the main thread. What is really frustrating is that I sold nearly every vehicle and expected the game to run fine at month end – it didn’t. Even more frustrating is that the performance is perfectly fine for the rest of the month (but even worse at year end strangely).

    According to Steam I have done 244 hours in TF, probably my most played game in several years. It is such a shame to be marred by this problem. Is there any news on this being solved? Can I do anything to help provide information on this?

    #16950
    Xcenty
    Participant

    The end of month pause doesn’t make the game “unplayable”. I’m on a I3 laptop. I played 130 years now with good cities (average pop 1700. Biggest 2200). Sometimes I’ve no pause at end of month, sometimes I have to wait 2 or 3 seconds. The huge pause you mention at end of year is only the autosave feature.

    The size of the save is linked to the settings of the map and the data present on the map (citizens, paths, vehicles, …)

    I’m playing on a little map. In the early game, the save game was 40 Mb, now it’s 110 Mb. I think they should maybe code the game like FIFA Manager, creating a database and populating it as you play. (path finding can be stored in database with streets data, bus stops data, …) When a change is made (new street, deleted street, delete bus stop), Event is called to modify the path and write the result back in database.

    • This reply was modified 5 years, 11 months ago by Xcenty.
    #16954
    HPoltergeist
    Participant

    Guys, it’s not quite about the end of month lag.

    It’s about the general lag in game (maybe end of month too) and after building and converting a road segment. To build a tramway or convert the roads between cities takes ages this way.

    The huge pauses at autosaves are probably because the game makes 250MB saves. As I’ve seen.

    HP

    #16957
    tomtom
    Participant

    I’m getting decent performance throughout the month, it is only the end of month issue for me right now. Perhaps when I ever “finish” a game and get to the year 2000, this might be an issue. However, with the month end performance set to get worse, I doubt I will get there.

    Yes end of year is the saving issue, but the saves are going to an SSD. Like everything else, the saving mechanism should ideally be asynchronous (where hardware permits). I can live with that once a year lag if the end of month lag was not so persistent.

Viewing 15 posts - 1 through 15 (of 21 total)
  • The forum ‘Support’ is closed to new topics and replies.