The NVIDIA OpenGL driver lost connection

Home Forums Support The NVIDIA OpenGL driver lost connection

Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
  • #5084

    I am experiencing a crash to desktop with this message after playing a random amount of time (sometimes it crashes after a couple of minutes…sometimes only after 30mins):


    The NVIDIA OpenGL driver lost connection with the display
    driver due to exceeding the Windows Time-Out limit and is unable to continue.
    The application must close.
    Erros Code: 7

    I’m experiencing the same problem.

    I have Nvidia 240 GT with most recent drivers (340.x)

    I found that the crash happens usually when I zoom in, or when it is already zoomed in and city, a bus or a train gets into focus.


    Same here… happened just once before now, now on a medium map @~1935 quite well devolepd it is crashing with this error dialog almost always after a few minutes from successful load of the savegame..


    If you haven’t already done so, please try to adjust TDR-related (Timeout Detection and Recovery) registry settings. These can be found by running regedit.exe and navigating to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers. If the settings (keys) are not there, they have to be created (with type REG_DWORD).

    The first option is to increase the timeout threshold by setting TdrDelay to a larger value (e.g. 10). If this doesn’t help, TDR can be disabled altogether by setting TdrLevel to 0.



    Ive already tried that a few  times…

    When i set it to a minute it only made my machine hang for a minute.

    I also set graphics settings to lowest. However enabling high resolution textures seems to have made crashes less frequent.

    I haven^t had a crash since latest patch. The problem might have been related to texture loading which latest patch contained a fix for.


    Next time the crash happens i will try disabling threaded optimization in nvidia control panel





    Just had three consecutive crashes. Disabling threaded optimization had no effect at all.

    Crash still happens when I zoom in to a city, or zoomed in and scroll the view.


    Can we expect this bug to be fixed or should I begin to look for a new card?


    I experience the same bug. This happens after a few minutes of playing Train Fever, in different situations, so I do not have a clear reproduction instruction. Unfortunately the game can not be played like this.

    Switching TDR off (TdrLevel=0) leads to a full computer hang instead of a TrainFever crash. Is there a way I can provide you with more debug information, or some some low-level gl settings I can try?


    • lowest Graphics settings
    • TrainFever  build 4831
    • Nvidia GT240, driver 340.52
    • Windows7 64bit
    • Quad-Core  Core2Duo Q8400@2.66 Ghz
    • 4GB Ram






    Actually, this always happens the first time a train leaves the depot….sometimes it doesn’t crash for 30mins, but as soon as the first train is ready to go and starts disaster strikes.


    You are the lucky one my windows 8 tells me that no gldriver is compatable so I cannot play the game at all.


    Same problem here.

    • Windows 7 – 64 bits (spanish)
    • Intel i5 -6 GB RAM
    • Nvidia 240 GT
    • Nvidia 331.82 drivers

    Game is unplayable so crashes before 10 minutes of playgame

    Any update? Or money back?


    Still no solution?

    I’ve buyed an unplayable game and there isn’t a simple response from the team.

    We’ve no game, we’ve no money and you’ve no solution. Really sad.


    We don’t have enough information to exactly write a solution. There are multiple causes for the connection loss of the opengl driver.
    Could you please try to set the power management to maximum in the Nvidia Control Center:
    NVIDIA Control Panel > 3D Settings > Manage 3D settings
    Power management mode: Prefer maximum performance
    Have you already tried different graphics settings (low/high textures, color-depth)?


    Ok, thanks for your response.

    I was trying different settings. The game still crashes applying the “maximum performance” setting in NVIDIA Control Panel. Low or high graphics quality settings has no effect in crashes.

    The crashes appear tipically when I zoom into a city.

    The only way I could play the game without crashes (at least 10 minutes) is lowering resolution, from 1600 to 1024 or 1280. I will try this resolution for a longer time and I will explain you how it works.



    I was playing a little more and unfortunately game stills crashes using lower resolutions, but it takes longer to do it.

    Please, we need a solution.

Viewing 15 posts - 1 through 15 (of 27 total)
  • The forum ‘Support’ is closed to new topics and replies.