[TOOL] Train Fever Model Converter

Home Forums Modding [TOOL] Train Fever Model Converter

Tagged: , ,

Viewing 15 posts - 31 through 45 (of 74 total)
  • Author
    Posts
  • #7053
    olahaldor
    Participant

    I found the error and have reported back to SpoorObjecten. You’ll have your trains soon enough, Jonathan 🙂

    #7062
    Pedro
    Participant

    so what was the problem, he had RLE compression enabled when saving the texture?

    #7066
    SpoorObjecten
    Participant

    Well it looks like it’s working for Ola now (thanks!) but not for me yet.

    Weird stuff 😛

    #7118
    SpoorObjecten
    Participant

    Unfortunately no luck. Ola is suddenly having the same issue 🙁

    I give up for now, here is the zip with the files:
    DOWNLOAD

    And this is where they are supposed to be in your TF directory:

    res\textures\models\vehicle\train\virmtf.tga
    res\models\material\vehicle\train\virm_tf.mtl
    res\models\model\vehicle\train\virm_tf.mdl
    res\models\mesh\vehicle\train\virm_tf\virm_tf_1.msh
    res\models\mesh\vehicle\train\virm_tf\virm_tf_1.msh.blob

    Anyone any clue what is happening?

    • This reply was modified 7 years, 9 months ago by SpoorObjecten.
    #7121
    olahaldor
    Participant

    I made it all lowercase, and made sure the train model was loaded only once instead of multiple times. So I made the .mdl file load load the NoHab axles instead of the VIRM_TF files two times over again.

    #7271
    SpoorObjecten
    Participant

    Yes it’s weird that it worked once for you and then stopped working.

    So I’m unsure if it’s something with the mesh, or the files around it.

    #7293
    Jonathan078NL
    Participant

    Great to see you working so eagerly to get this to work, my greatest respect for you guys, Modeling seems to be a difficult, creative and intelligent work.

    #7393
    Pedro
    Participant

    @SpoorObjecten

    as i said, it looks like you had RLE compression enabled when you saved your texture, i saved it again without compression and it worked, but you might want to rotate your model 🙂

    PS:  if anyone needs a normal map, add me on steam(http://steamcommunity.com/id/PedroTakeshi/), i have MindTex

    • This reply was modified 7 years, 9 months ago by Pedro.
    #7396
    SpoorObjecten
    Participant

    Thanks Pedro,

    It was indeed the compression, after fixing this it started working!

    #7400
    trainjunkie
    Participant

    Hi, I hope I’m not missing something obvious here but I am having trouble with scaling when exporting from 3ds max in a .3ds format, and I couldn’t find any info on this, how do you guys manage it? I tried playing around with the units preferences in 3dsmax but to no avail…

    #7443
    olahaldor
    Participant

    The model needs to be modeled to measurements, in meters. I’m not familiar with 3Ds Max directly, but I’ve had a hard time using models from 3Ds Max from other artists because it seems like most of the time they model, but don’t care about real world measurements.

    If you can have 3Ds Max show real world units in meters, scale your model to the appropriate size, and then export/convert.

    #7510
    trainjunkie
    Participant

    When I scale my object and set unit in meters (there is a unit preferences) it doesn’t seem to work (model is waay to big), so either I am missing something or there is a problem when exporting from 3ds max, but I am really rather a beginner at the whole 3d modelling thing. Maybe I should try and use another 3d program , I only use 3ds max because of free academic access. Your tutorial video is awesome BTW.

    #7514
    Tattoo
    Participant

    In 3DS Max, if your unit scale is set to inches/feet and your model was made using it, just close out your model file, then change unit scale to meters, then reopen your model and don’t convert units. It should be at the proper scale then.

    I know this works because I’ve done it before.

    #7516
    Tattoo
    Participant

    EDIT: Oh wait, I think you have to convert units. Sorry, it’s been a while since I’ve done it. If you can’t get it to work. reply back and I’ll figure out the correct way to do it. Like I said above, I know it works because I’ve done it many times when importing MSTS models.

    I like working in inch/feet. Then I just do what I said and it’s in meters then.

    • This reply was modified 7 years, 9 months ago by Tattoo.
    #7519
    Tattoo
    Participant

    @Pedro

    PS:  if anyone needs a normal map, add me on steam(http://steamcommunity.com/id/PedroTakeshi/), i have MindTex

    What is Mindtex? Is it a program I can get or do you have to make the normal map for us?

    Thanx

Viewing 15 posts - 31 through 45 (of 74 total)
  • The forum ‘Modding’ is closed to new topics and replies.