weird main connections

Home Forums Support weird main connections

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #19985

    Hi, as part of an upgrade to my train system, I needed to get longer platforms which required a reconstruction of the road network surrounding the station in question, however when attempting to do so the message “main connection – need bypass first” pops up, which is to be expected as there are a few industries around it. So I make a bridge and a connection far enough away to do the work and attempt to destroy the roads in the way. This is where I ran into the problem, the bulldozer tool still refuses to demolish the road as apparently its still a main connection even though I can see the bridge a few meters away is fully connected. I then looked around the place trying to see if it just neded updating (troubleshooting from minecraft redstone days, its basically the only other game I really play) and I noticed that even though I can deleate half a section of road further up, its not allowing me to demolish the second half even though it goes absolutely no where. At the moment the problem is semi fixed as I moved the new station further down the road at the cost of >5M (instead of the predicted 2M) but even a few years later its still not allowing me to get rid of the road.



    I hate that, and its why I play with the no connection mod enabled. Lol

    I only use it to make sure I can delete a nuisance road should I need to.

    Although I have been known to delete a road to stop goods walking to cities instead of taking my train…. Still don’t know why it does that. Lol (train travels at 100kph, walking 5kph…Hmmmmm, the train depot is even unloads in the middle of blue zones, but cargo will still try and walk it. Lol)

    If you’re not fussed about achievements, then I suggest enabling the mod. If you’re trying to unlock the 1900 and 1950 start, then you just need to persist. Lol


    I’ve see exactly the same problem.  You can usually fix it by saving, exiting and then re-starting the game.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Support’ is closed to new topics and replies.