I can't create or load game after update

Home Forums Support I can't create or load game after update

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #5228

    An unhandled win32 exception occured in TrainFever.exe.

    Game version: Build 4234 Windows 64-bit

    Windows version: Windows 8 64-bit

    Stucks on: 74% – Initialising simulation



    PreventSetUnhandledExceptionFilter: 1

    locale name: * (en_US.utf8)





    Startup at Sat Sep 06 22:24:02 2014





    seed: 1410035042

    alpha: 0 bits, depth: 0 bits, stencil: 0 bits, double buffering: 1, sample buffers: 1, samples: 4, swap interval: 1

    samples: 4



    OpenGL version: 3.2.0

    Renderer (vendor): GeForce GT 630M/PCIe/SSE2 (NVIDIA Corporation)

    Shading language version: 1.50 NVIDIA via Cg compiler




    opened device OpenAL Soft


    alpha: 0 bits, depth: 0 bits, stencil: 0 bits, double buffering: 1, sample buffers: 0, samples: 0, swap interval: 1

    opened device OpenAL Soft



    new game: seed=2142958959, startYear=1850, numTiles=8


    begin adding 27 locations..

    added 24 locations. took 0.560405 s.

    begin adding 135 locations..

    added 131 locations. took 14.2285 s.

    CreateTown: 4354.02 ms

    CreateTown: 660.298 ms

    CreateTown: 789.455 ms

    CreateTown: 848.555 ms

    CreateTown: 714.841 ms

    CreateTown: 633.533 ms

    CreateTown: 882.953 ms

    CreateTown: 813.193 ms

    CreateTown: 773.911 ms

    CreateTown: 680.256 ms

    CreateTown: 668.35 ms

    CreateTown: 825.231 ms

    CreateTown: 807.024 ms

    CreateTown: 660.751 ms

    CreateTown: 881.791 ms

    CreateTown: 764.61 ms

    CreateTown: 832.192 ms

    CreateTown: 641.688 ms

    CreateTown: 1066.71 ms

    CreateTown: 975.156 ms

    CreateTown: 1183.14 ms

    CreateTown: 1029.36 ms

    CreateTown: 1139.61 ms

    CreateTown: 1166.26 ms

    c:\urban\dev_steam_x64\trunk\src\game\urbansim\buildingsimulation.cpp:36: `anonymous-namespace’::CalcSimBuildingSrcCapacity: Assertion `(int)info->typeCountsAssigned.size() == to’ failed.

    MinidumpCallback: dumpPath “C:/Program Files (x86)/Steam/userdata/64051562/304730/local/crash_dump/”, minidumpId “e13aab75-5842-4f96-a863-c8e0a612a8b2”, succeeded 1


    c:\urban\dev_steam_x64\trunk\src\game\urbansim\initstreets.cpp:134: Verification of `checkTerrain’ failed.


    Please author, fix this wrong row of code or tell me how I can obtain 32bit version on steam instead of 64bit. It seems that this issue is in 64bit version only…


    Still no fix?


    Did you install any modifications or is it a clean installation? it seems like it’s a modified game.

    We did create the exact same map without any issues.


    I was created new mod, but after updating of game this  issue occured. I was removed game from steam, config too and reinstall. Now it´s clear install, but still this same issue. Before newest patch, game was worked with my mod. I’m programmer too and i hope that error is somewhere in 64bit version. Sadly, I haven´t access to 32 bit bersion of game or to previous versions of game via Steam.

    • This reply was modified 8 years, 8 months ago by Iver.

    To get a clean installation, make sure that the whole Train Fever folder of steam is empty and also that the settings and texture_cache  folder in the steam userdata folder are removed aswell:

    C:\Program Files (x86)\Steam\userdata\<user-nr>\304730\local

    A savegame  can also get corrupt if the mod does not perform correct.


    Ok. my mistake. It’s working now. In Steam/Train Fever there was few undeleted files. One of them can caused this issue. Sorry, “(int)info->typeCountsAssigned.size() == to” looks like not whole row of code for me and i was confused. Thank you, can be closed. And good luck with begining of game’s life. I’m working on my own Steam game now and this difficult period is waiting for me too.

    • This reply was modified 8 years, 8 months ago by Iver.
Viewing 8 posts - 1 through 8 (of 8 total)
  • The forum ‘Support’ is closed to new topics and replies.