The NVIDIA OpenGL driver lost connection

Home Forums Support The NVIDIA OpenGL driver lost connection

Viewing 12 posts - 16 through 27 (of 27 total)
  • Author
    Posts
  • #16365
    medopu
    Participant

    wefer, I had crashes every two years. But then i started to save every 5 or 6 months and before&after doing anything major with infrastructure and crashes still exist but they’re noticably less common (I just played 15 years with no crash today), and i’ve been doing this “trick” for a week now.

    Yes you will still crash but much rarely. This is what i’ve found out works for me for now. Not an optimal solution but i am at least able to play this game normally (i still have major lags)

    #16394
    mikael
    Member

    @wefer & @medopu

    You do get the “openGl driver lost connection” message when it crashes or is there a different message?

    Have both of you tried to change the power settings in the nvidia control panel?

     

    #16434
    medopu
    Participant

    I get same error message.

    Today i tried the power settings change. So far i played 8 years from 1966 to 1974 to see if i could produce a crash but so far, no crash. Will report more when i have more oppurtunity to play.

    #16436
    mikael
    Member

    This sounds great, we found following article regarding the lost connection error:

    http://www.instructables.com/id/How-to-Fix-the-Nvlddmkm-Error/?ALLSTEPS

    #16719
    wefer
    Participant

    Well, I tried all the solutions from previous link:

    • Solution 1: power supply “high performance” mode. CRASH
    • S2: changing the Theme. CRASH
    • S3: New drivers. CRASH
    • S4: Windows update. MY WIN7 IS UP TO DATE FROM BEGINNING.
    • S5: Changing time in registry. CRASH.
    • S6: Take out RAM. MY RAM IS OK, ONLY TRAIN FEVER IS FAILING.
    • s7: Better cooling. I’VE A HUGE COOLER SYSTEM KEEPING GRAPHIC CARD AND CPU TEMPERATURE BELOW 40º CELSIUS.
    • S8: New card. SORRY, I CAN’T BUY A NEW CARD ONLY FOR ONE GAME.

    This proposed solutions makes crashes less often (every 20 minutes), but it’s still unacceptable.

    Any ideas?

    • This reply was modified 7 years, 5 months ago by wefer.
    • This reply was modified 7 years, 5 months ago by wefer.
    #16730
    medopu
    Participant

    i don’t know, when all else fails … just keep saving the progress twice a year. It’s not a solution, but it kept me from crashing and … that’s just the thing you have to do.

    It reminds me so much of SC4. Same problems. Crashes, and crashes, unless I save the game often.

    As i said, before the “high preformance” mode and before the latest patches, i had crashes, and saving helped reducing the crashes for me.

    Now, after i’ve applied some solutions and patches,  i’ve only had one crash in 30 hours of gameplay. As far as my opinion is concerned, this isn’t a problem worthy of complaints from my part anymore, especially since it runs a bit smoother too as well with smaller end-of-month lags.

    Good luck 🙂

    #17044
    wefer
    Participant

    I applied last patches and game is still crashing.

    Last play lasts about 2 minutes until crashes. Very disappointing game.

    #17065
    Xcenty
    Participant

    What do you have in event viewer at the moment of the crash ?

    Do you have other applications running in background ?

     

    I had the problem of BSOD TDR with some games running in Direct3D and applied the ENB antifreeze patch (normally for skyrim) and it resolved all my issues. (Sadly it’s not OpenGL)

    • This reply was modified 7 years, 4 months ago by Xcenty.
    #17070
    wefer
    Participant

    Event Viewer:

    Log Name:      Application
    Source:        NVIDIA OpenGL Driver
    Date:          20/02/2015 19:55:58
    Event ID:      1
    Task Category: None
    Level:         Error
    Keywords:      Clásico
    User:          N/A
    Computer:      PC
    Description:
    The NVIDIA OpenGL driver lost connection with the display driver due to exceeding the Windows Time-Out limit and is unable to continue.
    The application must close.

    Error code: 7
    Visit http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=3007 for more information.
    Event Xml:
    <Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event”&gt;
    <System>
    <Provider Name=”NVIDIA OpenGL Driver” />
    <EventID Qualifiers=”49152″>1</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime=”2015-02-20T18:55:58.000000000Z” />
    <EventRecordID>77196</EventRecordID>
    <Channel>Application</Channel>
    <Computer>PC</Computer>
    <Security />
    </System>
    <EventData>
    <Data>The NVIDIA OpenGL driver lost connection with the display driver due to exceeding the Windows Time-Out limit and is unable to continue.
    The application must close.

    Error code: 7
    Visit http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=3007 for more information.</Data>
    </EventData>
    </Event>

    —————————————————————————————————————-

    And several seconds later, another one:

    —————————————————————————————————————-

    Log Name:      Application
    Source:        NVIDIA OpenGL Driver
    Date:          20/02/2015 19:56:26
    Event ID:      1
    Task Category: None
    Level:         Error
    Keywords:      Clásico
    User:          N/A
    Computer:      PC
    Description:
    The NVIDIA OpenGL driver detected a problem with the display driver and is unable to continue. The application must close.

    Error code: 3
    Visit http://www.nvidia.com/page/support.html for more information.
    Event Xml:
    <Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event”&gt;
    <System>
    <Provider Name=”NVIDIA OpenGL Driver” />
    <EventID Qualifiers=”49152″>1</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime=”2015-02-20T18:56:26.000000000Z” />
    <EventRecordID>77200</EventRecordID>
    <Channel>Application</Channel>
    <Computer>PC</Computer>
    <Security />
    </System>
    <EventData>
    <Data>The NVIDIA OpenGL driver detected a problem with the display
    driver and is unable to continue. The application must close.

    Error code: 3
    Visit http://www.nvidia.com/page/support.html for more information.</Data>
    </EventData>
    </Event>

     

    #17113
    Xcenty
    Participant

    Did you try to roll back to an older version of Nvidia Driver ?

    #20455
    Invidit
    Participant

    “Try this”, “Reinstall that”, “Move those”, “Make a tribal dance around PC”….

    If you don’t know the solution, stop saying silly stuff for do time wasting to frustrated players. The only culprit for the failure is the game for some incompatibility with Nvidia cards, and the only solution is that programmers fix it once for all. If they can’t, they should warn the user before they pull their money.

    • This reply was modified 6 years, 8 months ago by Invidit.
    #20467
    Invidit
    Participant

    Solved my own nvidia opengl driver crashes. There’s two things (at the moment) that caused it:

    1- Very long hight speed rails with catenary (solution: build simple rails and then upgrade it)

    2- Build something in an area with nearby crops (solution: just delete it with terrain tools)

    No TdrDelay (all it does is take longer to return to the desktop), no graphics settings, no resolution, no drivers; just a bug of the game graphics. Everything else has been a loss of time.

Viewing 12 posts - 16 through 27 (of 27 total)
  • The forum ‘Support’ is closed to new topics and replies.