Still have performance issue.

Home Forums General Discussion Still have performance issue.

Tagged: 

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #11953
    omoikane
    Participant

    Yes, some of them are fixed but still very slow on large map with biggest city over 2000 pops.

    that’s not so slow when paused, but when simulation started framerate dropped to one digit.

    Anybody else who gets same issue?

    Lowering graphic option does not help either. At the beginning of the game, everything runs smoothly.

    • This topic was modified 6 years, 3 months ago by omoikane.
    #11972
    NLTops
    Participant

    Game doesn’t slow down due to all the graphics, but for choosing destinations and routes for all the individual citizens and goods I think. Not to mention the location of every moving object.

    • This reply was modified 6 years, 3 months ago by NLTops.
    #11985
    FX2K
    Participant

    I started a new game yesterday in 1900 without mods to test the performance, I have just hit 1970.
    The performance has improved massively in numerous areas such as:

    • Lines menu no longer drops 1/2 the fps
    • Following a vehicle no longer drops 20fps
    • Rotating the camera is much smoother
    • Zooming in and out is much smoother
    • Viewing the horizon has less of an impact.

    The game still drops to between 15 – 25 in various areas / views but the above changes have made a massive difference for me making it much more playable.. its not perfect but It used to become unplayable by 1950 on a small map for me, its not hit this stage yet on a medium map..

    • When the vehicle needs replacing notice comes up, due to the PIP it lags
    • When buying 8 new trucks, it lags (again due to PIP I’m guessing) But I pause at this point anyway.

    *reason for new game was that some of the mods I used where causing a crash after the patch.. so couldn’t test existing saves 🙁

     

    #12038
    omoikane
    Participant

    @FX2K How many people in largest city there?

    I feel lines menu and following vehicle slowdown is much smoother than before, but still slow when map has large population (not so different even changed graphic option to lowest, or move camera to less populated area)

    #12075
    FX2K
    Participant

    I don’t know exactly at the time of posting but I would hazard a guess at around 800 in the largest and 350’s for most of the others with one or two below that.  I am starting to notice a lot more slowdown’s now though, around 1990 ish.

    I think it would be beneficial for the dev’s to make changes similar to below:

    • When buying a vehicle, don’t open the vehicle window itself.. you have the depot display for that.
      I only have to spam the close button for each, since I want to keep some windows open DEL is not an option.
    • When notifying that a vehicle needs replacing, either limit the window to 1.. or don’t show a PIP.

    I took a series of screenshots showing the effect these unavoidable PIP windows can have on performance.
    The game was paused in 1978 and I let the FPS settle before taking the screenshots.
    Its fairly typical of what its like in my game.

    41FPS – Looking over a city:  http://i.imgur.com/jxSDcnU.jpg

    30 FPS – With a single vehicle window open:  http://i.imgur.com/l3Bg1lk.jpg
    25 FPS – With two vehicle windows open:   http://i.imgur.com/xGVnyKI.jpg
    21 FPS – With three vehicle windows open:  http://i.imgur.com/cDZ79eR.jpg
    7 FPS  – With 15 vehicle windows open: http://i.imgur.com/tSvZ1r3.jpg

    30 FPS – With 15 vehicle windows open, but on the details tab (no PIP):   http://i.imgur.com/ZLhsgAL.jpg

     

    • This reply was modified 6 years, 3 months ago by FX2K.
    • This reply was modified 6 years, 3 months ago by FX2K.
    #12082
    uzurpator
    Participant

    The game suffers from several typical “newbie” mistakes. Mostly around the UI, but not always. It overuses the ‘render to texture’ feature. That one is slow as hell. Most games will grudgingly use one or two RtR viewports. TF will happily open 100 of such windows. Another issue lies with, what 3D programmers call “batch count”. Generally, the usage of 3d API is not optimized, making too many heavy rendering calls for trivial issues. You can see this in, for example, line management window. Just go to any corner of the map, look away from the map, where  you get a very high frame rate, and open the line manager.

    I get a drop from 60fps to 40fps in such case. That is appaling.

    The simulation part of the game does not seem to all that slow, to be honest, its the graphics part that pulls it down.

    #12083
    FX2K
    Participant

    Further to above, I think I would prefer if there was only a single PIP window on screen and it not be part of each individual vehicle, think mini map like.

    The PIP window would show the currently selected vehicle or vehicle from the current window you have active.
    The vehicle windows could then be re-designed slightly to show some of the important buttons on the first tab, like send to depot.

     

    #12124
    omoikane
    Participant

    There’s still some graphical lags but I think it’s from simulation (perhaps pathfinding)

    Because if there’s less than 1000 pops from largest city, performance is not bad. and when population gets bigger and bigger, performance is worse and worse. Pops over 2000? almost skipping. lowering graphic option isn’t different from before and move camera to less populated area (edge of screen where city has only less than 1000 pops) almost same performance issue than before.  when simulation is paused, there’s only few performance issue. everything is flawless and very fresh.

    I have played Cities in motion 2 with much more population (over 100k) but there’s no such issue.

    • This reply was modified 6 years, 3 months ago by omoikane.
    #12127
    FX2K
    Participant

    There’s still some graphical lags but I think it’s from simulation (perhaps pathfinding)

     

    Move the camera so you are looking away from the map and watch the performance..

    Aside from the monthly lag / auto save, it should be high FPS and consistent, well VSync is on by default, so 60fps for me.  At the end of the month, doing this, I get -8fps drop.  Then around the 12th of each month a further 8fps drop, both lasting about two seconds.

    The fact that it runs at very high frame rate when looking away from anything graphical tells me its more about the rendering than the simulation / path finding, I might be wrong of course, but if it was the simulation, surely it wouldn’t matter where my camera was pointing and I would notice similar performance hits.
    When playing, its not the occasional drop I get, its a constant fluctuation of low / high.

    Looking over a city, with 800 population, I can hit lows of 14 fps and highs of 43 fps (with no vehicle or other windows open)..

    Anyway, I have set geometry to low (+15fps versus high) and ambient occlusion off (+8fps versus on) which has helped quite a bit to be fair.

    • This reply was modified 6 years, 3 months ago by FX2K.
    • This reply was modified 6 years, 3 months ago by FX2K.
    • This reply was modified 6 years, 3 months ago by FX2K.
    #12137
    vincentmichau
    Participant

    where i can find the file build (build 4519 i don’t find it ….

     

    can you help me

     

    url ?

    #12150
    FX2K
    Participant

    where i can find the file build (build 4519 i don’t find it …

    I have the steam version which auto-updates, not sure where the updates would be for non-steam versions, sorry.

    #12155
    Tattoo
    Participant

    I’m getting lag when building roads, even before the new version. Anyone else notice this? It’s fine when building track, but when I build roads, the game gets very jerky and sluggish until I get out of the road building window.

    • This reply was modified 6 years, 3 months ago by Tattoo.
    #12167
    omoikane
    Participant

    FPS from most populated area with station (pops 2200) in 1966 when simulation is STOPPED – 30 fps

    FPS from most populated area with station (pops 2200) in 1966 when simulation is STARTED – 3(three) fps

    FPS from edge of screen (no population) in 1966 when simulation is STOPPED – 60 fps

    FPS from edge of screen (no population) in 1966 when simulation is STARTED – 3(three) fps

    FPS from most populated area with station (pops 727) in 1905 when simulation is STOPPED – 35 fps

    FPS from most populated area with station (pops 727) in 1905 when simulation is STARTED – 30(thirty) fps

    Playing simulation makes game almost skipping when population is large, while stopping does not show difference from much less population.

    I don’t care 60 fps -> 30 fps caused by nearby structures, vehicles, people, etc. but I do care so much 30 fps -> 3 fps caused by playing simulation.

    • This reply was modified 6 years, 3 months ago by omoikane.
    #12176
    SFG
    Participant

    Yes the Perfomance is better then before now and it will take longer before the Games is getting boring …….but it only needs longer to get boring lol….so there is a Long way to got till the game perfomance will be very good in late games ……im looking Forward to new patches and improvements in the future so that also big maps are payable with big towns….. for the Moment im only playing small maps with only 1 town up to 2000+ citizens……..and now the game lags are coming back and the perfomance is dropping down more and more every year of gameplay.

    greetings Markus

Viewing 14 posts - 1 through 14 (of 14 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.