Game unplayable after new Mac version update

Home Forums Support Game unplayable after new Mac version update

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #12249
    Brightlands100
    Participant

    As the title says.  After a Steam auto update to the latest version for my iMac the game is unplayable.  The mouse cursor is very slow to move across the screen and often freezes.  Zooming in and out is slow and jerky.  The game crashes after a couple of minutes and the error message reports ‘A graphics issue’.

    The game worked perfectly well before this update.  Any advice please?

     

    #12307
    Brightlands100
    Participant

    Still waiting guys….. I’d appreciate a response from support please.  My graphics details are as follows:-

     
    NVIDIA GeForce GT 650M:

      Chipset Model:NVIDIA GeForce GT 650M

      Type:GPU

      Bus:PCIe

      PCIe Lane Width:x16

      VRAM (Total):512 MB

      Vendor:NVIDIA (0x10de)

      Device ID:0x0fd5

      Revision ID:0x00a2

      ROM Revision:3707

      Displays:

    iMac:

      Display Type:LCD

      Resolution:1920 x 1080

      Pixel Depth:32-Bit Color (ARGB8888)

      Main Display:Yes

      Mirror:Off

      Online:Yes

     
      Built-In:Yes

    iMac info

      Model Name:iMac

      Model Identifier:iMac13,1

      Processor Name:Intel Core i5

      Processor Speed:2.9 GHz

      Number of Processors:1

      Total Number of Cores:4

      L2 Cache (per Core):256 KB

      L3 Cache:6 MB

      Memory:8 GB

      Boot ROM Version:IM131.010A.B05

      SMC Version (system):2.9f5

    I’ve recently upgraded to Yosemite

    #12310
    FX2K
    Participant

    Whilst you wait a dev reply… which I hope you get….what in game graphics settings do you have?
    Have you tried (for testing of course) setting everything to its lowest, including textures and colour depth?

    #12322
    Brightlands100
    Participant

    At least someone replies.  Thank you!

    To be honest I haven’t tried lowering my settings as they have been running well up to now.  But it’s a good idea and I will try lowering them.  Thanks again.

     

    #12325
    Brightlands100
    Participant

    Thanks FX2K.  I dropped the settings back to low and at least the game is now playable with no crashes.  It’s not as smooth as it was though and considering the last update was to fix performance issues it’s done no favours to users on the Mac version.  I hope that this can be fixed in a future Mac-specific update.

    #12326
    FX2K
    Participant

    For what its worth, I play with low textures/colour, no ambient occlusion and low geometry.. My system is high end PC and handles every AAA game I throw at it with ease… just not Train Fever lol… they still have some work to do in that respect, at least I hope they do.

    #12377
    Brightlands100
    Participant

    This is still a problem.  Just played for less than 5 mins with all graphics settings on low and got the frozen screen followed by the software quitting with the graphics error message to send to Apple.

    What puzzles me is how some problems on this ‘Support’ forum get a response and others do not.  Even if a solution is not immediately available, a simple ‘we’re looking into this’ would be appreciated.  But no reply at all makes me very annoyed.

     

    #12383
    FX2K
    Participant

    I might be wrong, but it seems to me like somebody has taken a week off.  Mikael hasn’t appeared recently.
    http://www.train-fever.com/forums/user/mikael/replies/

    And Mr Urban doesn’t post much:
    http://www.train-fever.com/forums/user/urban/replies/

    No doubt they would tell you to check you have the latest video drivers installed, but IMO, its much more than just that.

    • This reply was modified 6 years, 3 months ago by FX2K.
    #12385
    Brightlands100
    Participant

    I think it is more than video drivers. OSX updates the drivers itself and since Yosemite is brand new then I guess that there’s nothing to update.  I give up until I see some response or update.

    #12661
    zahcim
    Participant

    yep – again – same problem here with 2014 15″ retina mac book max

    only steam streaming from my PC game rig in the cellar makes my working day on the mac 🙂

    cheers

    zahcim

    #12748
    mjmay2
    Participant

    I am having a similar problem on my Linux system, was working fine until this latest build, now it just hangs after the load game bar comes to 100%, or if I create a new world, it hangs just after the world is displayed.

    #12753
    mikael
    Member

    We’ve found an incompatibility regarding Max OSX 10.10, this will be fixed in the next patch.


    @mjmay2
    : According to the crash dump file you’re using the open-source driver (nouveau) for your graphics card. Please install the proprietary NVIDIA driver, preferably via your distribution’s package manager, or directly from NVIDIA: http://www.geforce.com/drivers/results/78469

    • This reply was modified 6 years, 2 months ago by mikael.
    #12755
    Brightlands100
    Participant

    Thanks Mikael.  I’m (a) pleased to get a reply and (b) pleased that you have identified the problem.  Good luck with fixing it soon.

    #12838
    mjmay2
    Participant

    Yeah, Awesome job Mikael!  I thought I had already blacklisted Nouveau.  Now I can start new games, but I still can’t load my old games – I saw on another thread that this may be a separate problem that you are aware of – so I’ll just wait for the next update and work on some new cities.  Really a wonderful game, and I’m just amazed by your support!

    #12844
    mjmay2
    Participant

    Actually I do have continuing problems – at the the 1852 game same, the game crashed after making the save – the hard drive is going like crazy even if left for 5 minutes.  I cut the power, rebooted, and could load autosave 1852, but then it crashed, I’m assuming at the 1853 autosave time (but without saving).

Viewing 15 posts - 1 through 15 (of 23 total)
  • The forum ‘Support’ is closed to new topics and replies.