Another OpenGL error at startup

Home Forums Support Another OpenGL error at startup

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #8558
    Haxor
    Participant

    Hi, I recently (well, tommorow) bought the game, installed it and I wanted to play it today.

    Then I saw the popular as I can see error with OpenGL, “context creation failed”.

    I use nvidia 610, I have the latest drivers, I have reinstalled them 2 times, I use the nvidia card at startup for 100%,

    Official nvidia site says that my card supports even OpenGL 4.5, so I guess 3.2 is also supported, right?

    Any help?

    I want to play already D:

    #8753
    Haxor
    Participant

    I was looking if my drivers really are the newest ones, and they are.

    I have reinstalled the game, and it still doesn’t work 🙁

    #9153
    Haxor
    Participant

    Help?

    🙁

    • This reply was modified 6 years, 10 months ago by Haxor.
    #9158
    bencze
    Participant

    No idea what OS is that, but if you had the spare space I’d try a small fresh OS installation (different supported OS perhaps) just to see if it’s not something borked in the OS itself…

    #9176
    Haxor
    Participant

    I use Windows 7 64 Bit.

    Every other game using OpenGL works well.

    I can’t really reinstall my OS, because it came with my laptop already preinstalled.

    #9432
    Haxor
    Participant

    Help

    🙁

    #9513
    mikael
    Member

    Could you please download this opengl-extension viewer

    http://www.realtech-vr.com/glview/download.php

    and submit a screenshot similar to this:

    http://s14.directupload.net/images/140716/i8istpag.jpg

    #9518
    Haxor
    Participant

    I took the screenshot, but it looks like the program doesn’t see my nVidia, even when I open it with it. (open the program with nvidia card)

    Maybe Train Fever doesn’t see it too somehow, thought my main card is the nvidia..

    http://www.directupload.net/file/d/3752/cx6eriua_png.htm

    #9528
    mikael
    Member

     

    Most common issues point 2

    http://www.train-fever.com/forums/topic/most-common-issues/

     

    Under the “manage 3d settings” tab in the nvidia control panel, you should be able to navigate to your game’s .exe and specify which GPU to use from there. 

    #9540
    Haxor
    Participant

    I did.

    it’s my default GPU.

    #9700
    Haxor
    Participant

    Fourth bump..

    #9707
    mikael
    Member

    As your screenshot shows, it does not select the correct gpu. So you did not do it right or you do have something else wrong with your system. I’m sorry but I can not fix your computer. This is a problem on your side.

    #9758
    Haxor
    Participant

    Uhh

    I can’t seem to fix it, I tried to make a clean reinstall of the drivers, and setting some stuff at Nvidia control panel, but nothing works D:

    #9787
    DaveR
    Participant

    @Haxor, I had to fight for 2 days with the same problem (Windows Notebook, with both Intel and AMD graphics). The solution for me was:

    1. Use origin drivers from laptop (NOT the latest from AMD)
    2. In BIOS, change graphic setting from “dynamic” to “fixed”

    Within these settings, finally, I was able to start Train Fever 🙂 Hope it will also work for you!

    #9801
    Haxor
    Participant

    Hmm

    Will try this too, just how to change the graphics card settings throught BIOS?

     

    EDIT: OKay, I will Google it.

    • This reply was modified 6 years, 10 months ago by Haxor.
Viewing 15 posts - 1 through 15 (of 23 total)
  • The forum ‘Support’ is closed to new topics and replies.